Instructions for using JMRI DecoderPro for programming Team Digital Decoders
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1. Programming with JMRI — DecoderPro reference
JMRI website: http://jmri.sourceforge.net/
DecoderPro manual: http://jmri.sourceforge.net/help/en/manual/index.shtml

2. Requirements:

Computer with USB or serial port, JIMRI (Decoder Pro) and a command station compatible with JMRI
or a Locobuffer.

For more details see: http://jmri.sourceforge.net/help/en/html/apps/DecoderPro/index.shtml

3. Programming overview:
This following diagram shows the document section numbers and the flow of using DecoderPro for
programming Team Digital decoders and the SIC24AD and BlocDS8.
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4. DecoderPro setup (create a roster file):
The goal is to create a roster file which provides for a way of storing the decoder CV values. It can be
used to program in Service Mode or Operations Mode. A roster file must be created while in Service
Mode. Once the roster file is saved it can then opened from Operations (Ops) Mode.
1. Open DecoderPro
2. Click on the Service Mode (Program Track) Programmer button in the center screen
OR alternately
* From the menu select Tools
» Select Programmers
» Select Service-Mode programmer
This opens the Service Mode (Program Track) Programmer Setup window

Click on the Set... button and select paged mode if not already selected
Select Programmer format as Custom from the pop up menu (at the button of the window)
Select Team Digital folder from the list
Select a decoder or open the Stationary Decoder folder then select a decoder
Click on the Open Programmer button
Select the Roster Entry tab
Type in a name for this decoder like ‘SRC16-1 main yard’ in the ID field (ID is the file name)
0. Click on the Save to Roster button
OR alternately
* From the menu select File
» Select Save
This will create a Roster File in DecoderPro that can be opened for Operations Mode
programming with the default ops address as one (1)
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11. At this point the decoder power terminals could be connected to the programming track and
programmed (It may be useful to change the decoder Ops mode address and/or basic
configuration here.) See section 5

12. Exit Service Mode i.e. close the Service Mode (Program Track) Programmer Setup window



5. Using Service Mode to program the Decoder from the program track:

Connect the decoder to the program track. Team Digital decoders are accessory decoders and do not
have any built in CV read back capabilities. Note: Some decoders may provide read back by adding an
external resistor. See the decoder manual.

If you came here directly from section 4 step 11, than you can skip to step 7 here and begin

programming.
1. Open DecoderPro
2. Click on the Service Mode (Program Track) Programmer button in the center screen
OR alternately
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* From the menu select Tools
» Select Programmers
» Select Service-Mode programmer
This opens the Service Mode (Program Track) Programmer Setup window

Click on the Set... button and select paged mode if not already selected
From the Use locomotive settings for pop up menu select the roster file for the decoder
From the Programmer format pop up menu select Custom (at the button of the window)
Click on the Open Programmer button
CV programming can start.
When finished go to the Roster Entry tab
Click on the Save to Roster button
OR alternately
* From the menu select File
» Select Save

Recommendations for minimum programming at this point:

If the the decoder has an accessory bus interface (Loconet®) and is going to be used than it should be
enabled. The bus on the SIC24AD is permanently enable from the factory.

If you want to change the ops address or always have ops mode enabled now is a good time. Ops mode
can temperately be enable via the “Smart” button.



6. Using Ops Mode to program the Decoder from track power :

The decoder is powered by the command station track power. If the decoder has an accessory bus
interface it is not used at this point and need not be connected.

(If you enable ops mode in service mode programming you can connect power to the decoder and then
skip to step 5.)

1. Be sure power is off by removing one of the power wires to the decoder
OR alternately
*  From the menu select Tools
* Select Power Control
* In the Power Control window click Off
2. Press and hold the Smart Programming button on the decoder
3. Turn on Power to the decoder by connecting the wire that was removed in step 1
OR if using the power control window
* Click the ON button
4. Release the Smart Button just after you see the Green LED come on. (Warning: If the red
LED starts to flash during this time the above steps were not completed correctly - start
over from step 1.)
5. The decoder is now ready to be programmed
6. Click on the Operations Mode (Main Track) Programmer button in the center screen
OR alternately
* From the menu select Tools
» Select Programmers
* Select Ops-Mode programmer
This opens the Operations Mode (Main Track) Programmer Setup window

Select Programmer format as Custom from the pop up menu
From the existing roster pop up menu select the roster file you created earlier
9. Click on the Open programmer button
10. At this point CVs can be programmed
11. When finished go to the Roster Entry tab
12. Click on the Save to Roster button
OR alternately
* From the menu select File
» Select Save
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Note: If a Function Label tab is present ignore it as it is not used by these decoders



7. Using Ops Mode to program the Decoder via Loconet®:

In a Digitrax system the decoder should be powered from a filtered DC power supply*. Otherwise (non-
Digitrax system) it can be powered by the track. If the decoder has an accessory bus interface
(Loconet®) it should be connected at this point.

(If you enable ops mode in service mode programming you can connect power to the decoder and then
skip to step 5.)

1. Be sure power is off by remove one of the power wires to the decoder
OR alternately
* From the menu select Tools
» Select Power Control
* In the Power Control window click Off
2. Press and hold the Smart Programming button on the decoder
3. Turn on Power to the decoder by connecting the wire that was removed in step 1
OR if using the power control window
* Click the ON button
4. Release the Smart Button just after you see the Green LED come on. (Warning: If the red
LED starts to flash during this time the above steps were not completed correctly - start
over from step 1.)
5. The decoder is now ready to be programmed
6. Click on the Operations Mode (Main Track) Programmer button in the center screen
OR alternately
* From the menu select Tools
» Select Programmers
» Select Ops-Mode programmer
This opens the Operations Mode (Main Track) Programmer Setup window

7. Select Programmer format as Custom from the pop up menu
8. From the existing roster pop up menu select the roster file you created earlier
9. Click on the Open programmer button
10. At this point CVs can be programmed
11. When finished go to the Roster Entry tab
12. Click on the Save to Roster button
OR alternately
* From the menu select File
* Select Save

Note: If a Function Label tab is present ignore it as it is not used by these decoders.

* In a Digitrax system the reason the decoder can not be powered from the track WHEN programming is
that the decoder will receive program instructions from the track and Loconet® at the same time. This
can be problematic. Once programming is complete the decoder can be power from the track. Note:
An alternate scheme to program using track power is to create a separate Loconet® bus as show in the
diagram below.

* Our products have CVs programmed at the factory. The fact that DP shows a particular CV as zero (if
no read back has occurred) does not mean the CV is zero. In custom programming every CV that you
use should be programmed even if zero. This is paricularly important with SIC24(AD)s.



8. Product programming reference:

The following table shows some of our products and the type of programming they support.
The product must be powered from track power to program via DCC Ops mode or from the
programming track to program via DCC service mode.

The product must have a LocoNet® connector to be programmed via LocoNet®.

Product DCC Service DCC Ops LocoNet® Service LocoNet® Ops
Mode Mode Mode Mode

SC8 write write read/write?

BlocD8 write write read/write?

SRC16 write write read/write?

SMD84 write write read/write?

SMD82 read/write? write

SMC4 write write

SIC24AD write write read/write?

SiC24 write read/write read/write

1. An external resistor is required to read - see manual

2. In a Digitrax system the decoder should be powered from a filtered DC power supply when
programming via Loconet®. The reason that the decoder can not be powered from the track WHEN
programming is that the decoder will receive program instructions from the track and Loconet® at the
same time. This can be problematic. Once programming is complete the decoder can be power from
the track. Note: An alternate scheme to program using track power is to create a separate Loconet®
bus as show in the diagram below.

Programming via Loconet with DecoderPro

Create a separate bus for programming
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8. SRC16 Specific:
This description details initial set up of a the SRC16 in a Digitrax system using DecoderPro (DP)
connected to Loconet®. The goal is to be able to write and read CV values in Ops Mode programming.

The SRC 16 is a stationary decoder but like a mobile decoder used in locomotives it has a two digit
address which resides in CV1. The default value is 1. This is strictly used for programming in Ops Mode
and has nothing to do with the SRC16 operating addresses (like turnout addresses). This needs to be a
unique number not used by other decoders.

CV9 in the SRC16 is similar to CV29 in loco decoders. It configures various options in the decoder that
control communications and output conditions. Options for CV9 are described in Section 4.4 (Page 6) of
the SRC16 manual. Initially CV9 can be set to 52 which enables OPS mode programming (4), LocoNet
communications (16) and disables track input commands (32).

Specific Programming
1. Create and save a roster file in DP off line in the Service Mode (Programming track) using the

comprehensive or custom panel for the SRC16. Ensure address in CV1 is unique. See section 4
of this document.

2. Connect the track inputs of the SRC16 to your Digitrax programming track. Using your throttle
in the Pg (paged mode) set program AD2 (CV1) to a unique address and CV9 to 52. Alternately,
the two CV’s can be written with DP in the service mode. See section 5 of this document. When
a CV is programmed LED 1 and 3 will light solid and LED2 will flash.

Note: The SRC16 does not have read back capability in the programming mode. It can be read in Ops
mode. Only AD2 (CV1) and CV9 are programmed initially to enable the remainder of programming to
occur in OPS mode. Programming the SRC16 in the Service Mode is slow because of the lack of
acknowledgement from the SRC16. Without feedback from the SRC16, DP sends multiple commands
for each CV. Both reading and writing CV’s takes place very fast in the Ops mode.

3. Disconnect the SRC16 track input from the program track and connect a 9 to 12VDC power
supply to the track input. Connect Loconet® to one of the RJ12 connectors on board.

4. Select Operations Mode (Main Track) in DP and select the roster file for the SRC16. See section
7 of this document. You can now read the Option Tab sheet to see the CV values that were
programmed is step 2 of this section. If you made any other CV changes in Service Mode, you
can now write those sheets. When a CV is programmed LED 2 will flash. LED 3 will be
indicating the normal heartbeat flash.



